Snippet creation/editing not working

Incident Report for ReelCrafter

Resolved

Snippet creation and editing is fully functional again. We appreciate your patience!
Posted Oct 20, 2025 - 15:50 CDT

Monitoring

We appreciate your patience today as Amazon Web Services (our cloud provider) experiences one of its biggest outages in years.

Snippet creation (and possibly editing) is affected by this outage. We're closely monitoring the situation and checking updates from the AWS team, and will keep you posted.
Posted Oct 20, 2025 - 15:25 CDT
This incident affected: ReelCrafter v2 (Web Application).